Linux実践講座

Linux実践講座

コンピュータを便利に使う tips などをメモ

--- 広告 ---
--- 広告 ---

php 5.4.x と 5.3.x  下位互換性がない関数を沢山使っているのでキビシイなぁ

読了までの目安時間:約 2分

今更ですが、サーバに php の ver 5.3.x をインストールすると、昔作って稼働しているプログラムが動かない事があるのでトホホ状態です。
 
下位互換性のない変更点
 
プログラムを作る時は出来るだけ php 5.4.x で動作するように作成していますが、昔作ったプログラムを新しいサーバの環境で問題なく動作させるのは思った以上に大変な作業になりそうです。
 
管理しているお客様のサーバを交換する時に、最新の OS を入れ、php も新しいバージョンをインストール。
以前作ったプログラムを新サーバにインストールして動作検証すると思ったように動作しない事がしばしばあります。
 
予算が潤沢だったら、プログラム修正して新しいバージョンで動くようにするんですが....。
 
仕事じゃなければ新しいPHPのバージョンで動作するように書き換えますが、うぅーん 悩ましいなぁ。
 

--- 広告 ---
--- 広告 ---

 

この記事に関連する記事一覧


最近の投稿
 
%d人のブロガーが「いいね」をつけました。